Support officiel calculateurs Megasquirt, Lambda Tech Edge WBO2, Tuner Pro, SportDevices et Fenixecu 

  • Rescue Flash sur 2Y2

  • Support pour le matériel d'acquisition de données Tech Edge. Si vous avez un problème avec votre matériel, ou une solution à un problème, c'est ici qu'il faut poster.
Support pour le matériel d'acquisition de données Tech Edge. Si vous avez un problème avec votre matériel, ou une solution à un problème, c'est ici qu'il faut poster.
 #9752  par rwangtt
 11 mai 2021 17:48
Bonjour

Suite au disfonctionnement de mon 2y2, resultant sûrement d'arrêt/démarrage trop rapide, j'ai tenté de flasher le firmware, avec succès.
Suite à cette manip, avant la remise en service, je décide de re-calibrer ma sonde lsu4. 2, mais impossible. Elle chauffe bien, mais la valeur IPX tourne autour de 4000 et le loggeur m'affiche 14.8 à l'air libre.

Je me dit alors que j'ai cramé ma sonde.
Mais après montage d'une autre sonde bosch lsu4. 2 fonctionnelle (celle de mon pote fonctionnelle lors du demontage sur son auto ), toujours impossible de la calibrer.
Et en plus mon afficheur affiche ND (pas de données transmisent par le loggeur).

J'ai ré-flashé, le loggeur, l'afficheur, mais rien n'y fait. Toujours ND sur l'afficheur et calibration à 4000.

Verif du câble sonde-loggeur: ras.

Je voudrais tenter le rescue Flash.
Mais impossible de trouver le jumper, ou la manip sur Wbo2. Com. J'ai pourtant lu tout les docs dispo au moins 2fois.
Soit je suis miro, soit je suis passé à côté.

Qu'elle est la manip hardware à faire pour lancer le rescue Flash sur 2y2 avec afficheur intégré ?

Merci d'avance
Erwan
 #9754  par Manu
 12 mai 2021 09:42
Salut Erwan,

Es-tu sûr d'avoir utilisé le firmware pour la version 2Y2D (display) disponible ici (et uniquement ici) :
http://wbo2.com/sw/hxf/l49_2y2_B063a.zip

Un Rescue-Flash ne doit être fait que si le flash normal ne peut plus se faire (plus de communication entre le logger et le PC).

Pour ce qui est de mettre le logger en mode "rescue flash", il faut mettre en contact 2 pattes du CPU, la patte 5 et 16 exactement. Regarde en haut de cette page sur la droite, il y a un dessin :
http://www.wbo2.com/2y/2Y1-schem.htm

++
Manu
 #9755  par rwangtt
 12 mai 2021 13:17
Salut Manu

Alors oui, j'utilise depuis le début le firmware du 2y2 avec display en lsu4. 2
Ça défile bien dans l'onglet Terminal.
Le fash se passe correctement.
Je flash bien afficheur lx1 débranché du loggeur.
Dans le 1er onglet, la ou on sélectionne le port com et le loggeur, le bouton READ reste non cliquable...

Sinon j'avais fait une bêtise:

Vu que le câble de la sonde de pote était très court, j'ai fait une rallonge avec le câble d'une sonde HS. De ce fait il y avait 2 résistance intégrée au connecteur sonde, ce qui explique la valeur IPX divisée par 2.

Une fois branché en direct sur le câble loggeur, j'ai bien une valeur IPX à l'air libre de 8190 (+ ou-20, c'est pas stable). Et la sonde chauffe beaucoup +.

Je remonte sur la ligne, démarre le moteur au ralenti, mais l'AFR lu par le loggeur varie entre 17 et 18, alors que mon AFR au ralenti est entre 12.5 froid à 14 chaud...
J'espère que j'ai pas nique la sonde de mon pote :oops:

Et l'afficheur m'affiche toujours ND....

Mzrci et à +
 #9761  par Manu
 13 mai 2021 10:12
Si le logger envoie les trames au PC, alors pour l'afficheur qui indique ND, c'est lui qui pose problème.
 #9763  par rwangtt
 15 mai 2021 08:00
Salut

OK je vais re-tenter de flasher l'afficheur.
J'ai une nouvelle sonde.
Je teste tout ça ce soir.

Merci et bonne journée
 #9767  par rwangtt
 17 mai 2021 14:27
Salut

Le flash du loggeur se passe bien,
le flash de l'afficheur se passe bien,
Une sonde bosch neuve, et la calibration se passe bien.

Toujours ND sur l'afficheur..

Dois-je tenter un reçue flash ?

Merci
Modifié en dernier par rwangtt le 17 mai 2021 21:33, modifié 1 fois.
 #9769  par Manu
 18 mai 2021 16:23
Tu as tenté de mettre une pile 1,5V sur l'entrée O2 du calculateur pour voir ce qu'il indique ?