Support officiel calculateurs Megasquirt, Lambda Tech Edge WBO2, Tuner Pro, SportDevices et Fenixecu 

  • Alpine GTA V6 3.0 24S

  • Vos montages, vos projets, vos remarques, c'est ici ;-)
Vos montages, vos projets, vos remarques, c'est ici ;-)
 #8463  par Gégé13821
 11 mai 2019 17:17
De l’influence de certains paramètres sur la Régulation de Ralenti en Boucle Fermée
Paramètre : Seuil de papillon fermé (Etats Moteur)
Image
Paramètre : Valeur à utiliser pour le calcul (Réglage de la boucle fermée de Ralenti)
Paramètre : Délai avant activation PIDs (Réglage de la boucle fermée de Ralenti)
Image
Phénomène à l'origine de la réflexion : En circulation - Moteur calé au ralenti - Aléatoire.

L'explication :
Au levé de pied, dès que la position papillon passe au dessous du Seuil de papillon fermé :
La vanne de ralenti se positionne à Valeur à utiliser pour le calcul, dans mon cas : la dernière valeur utilisée.
Dès que l'état moteur est "Idling", et après Délai avant activation PIDs, la régulation de ralenti se met en service.

Dans la majorité des cas, "la dernière valeur utilisée" correspond à un ralenti prolongé avec papillon fermé (45% dans mon cas) : tout se passe bien.

Mais en circulation, il arrive que l'on modifie la position du papillon alors que la Régulation de Ralenti est en service. Si l'ouverture du paillon est inférieure à "Seuil de Papillon Fermé" alors la vanne se ferme pour limiter la montée en régime (32% dans mon cas pour 1.5% ouverture papillon).
Quand la position papillon dépasse le "Seuil de Papillon Fermé", le système enregistre la dernière position de la vanne de régulation de ralenti.
Au prochain passage au ralenti (position papillon 0%), la vanne de régulation de ralenti prend la "dernière valeur connue" (32% dans mon exemple).
Si le paramètre "Délai avant activation PIDs" est important (3s dans mon exemple) le moteur a calé avant que la vanne ne s'ouvre. :ugeek: :ugeek:

Le phénomène aurait pu être évité si j'avais suivi les explications du manuel à la lettre :oops: :oops:
Manuel : Seuil de papillon fermé - En général compris entre 0.5 et 1% (sauf en cas de bruit trop important).
Valeur dans mon cas : 2% - Ecart inutile, le bruit ouverture papillon est nul :? :?
Manuel : Délai avant activation PIDs - Je n'ai pas trouvé de valeur préconisée.
Valeur dans mon cas : 3s - Jamais changé, je vais tester avec 1s.

Autres paramètres à optimiser :
Ajout au début de la boucle (%) : Permet de positionner la vanne au dessus de la dernière valeur pour commencer sur un ralenti accéléré (en attendant l'activation de la régulation).
................

Pffff, j'ai mal à la tête :roll: :roll:
Pour ceux qui veulent approfondir le phénomène je joins l'enregistrement
(440.13 Kio) Téléchargé 4 fois
 #8491  par Gégé13821
 18 mai 2019 19:36
Capteur Température Huile.

Encore un détail qui me résiste. :x :x
J'ai installé un capteur de température sur le circuit d'huile, une résistance de 2490 Ohms entre le 5 volts et l'entrée analogique sur la MS3.
Capteur déconnecté, je mesure 5 volts entre les deux bornes du connecteur.
Le capteur est déclaré dans TunerStudio :
Image
La calibration est faite :
Image
Et la valeur enregistrée est désespérément constante : de l'ordre de 20°C :oops: :oops:

La lecture du manuel :
4.4.1 Capteurs de température : Le MS3Pro est conçu pour fonctionner avec le type de capteur appelé thermistance NTC. NTC signifie coefficient de température négatif, et signifie simplement que la résistance diminue à mesure que la température augmente.
Peut être faut il lire le manuel de manière stricte : Le MS3Pro ne peut utiliser que les capteurs de type NTC (exit les capteurs PTC) :geek: :geek: édité le 20/05

Je vais tenter d'installer un nouveau capteur de température d'huile NTC.
Quelle référence de capteur utilisez vous ?
Plage de mesure ... - 130°C
Filetage : 14 x 1.5
Merci pour votre aide.

Edité le 20/05 : En réalité, je pense qu'en utilisant l'option "capteur de température personnalisé" - définition par 3 points de mesure, il est possible d'utiliser un capteur avec un coefficient de température positif.
Aux premiers essais, l'indication de température croit avec la température. Reste à vérifier l'indication pour des valeurs précises.
La suite ......
Modifié en dernier par Gégé13821 le 20 mai 2019 10:14, modifié 1 fois.
 #8492  par Manu
 19 mai 2019 01:49
Salut Gégé,

Tu ne peux pas tout simplement utiliser un capteur de température moteur ?

++
Manu
 #8493  par Gégé13821
 19 mai 2019 11:06
Manu a écrit :
19 mai 2019 01:49
.... Tu ne peux pas tout simplement utiliser un capteur de température moteur ? .....
J'y ai bien pensé, mais je réfléchis trop :mrgreen: :mrgreen:

Les courbes des sondes CTN de liquide de refroidissement ressemblent à :

Image
Image
Autrement dit, au dessus de 100°C, si on prends en compte la dispersion et la dérive dans le temps ...... on n'a pas vraiment de valeur précise !!!!!

Deux documents FAE trouvés sur le net qui expliquent le fonctionnement et/ou qui donnent des équivalences constructeur.
Malheureusement : pas de courbe !!!!
Info FAE Capt Temp
Equi FAE Capt Temp

Trouvé aussi sur le net des capteur de température référencés "type huile" par certains constructeurs, "type liquide de refroidissement" par d'autres :o :o

Prochaine étape : Fabriquer l’adaptateur pour monter un capteur avec un filetage qui semble être le plus courant : 12 x 150.

Petite anecdote sur la précision des capteurs de température : Sur l'ancien moteur équipé de 2 sondes de température d'eau (une indication tableau de bord - une pour le boîtier d'injection Renix), j'ai ajouté un thermocouple pour le contrôle.
Résultat : 105°C au calculateur, 90°C au thermocouple, 80°C au tableau de bord :oops: :oops:
 #8494  par Manu
 20 mai 2019 00:39
Gégé13821 a écrit :
19 mai 2019 11:06
Petite anecdote sur la précision des capteurs de température : Sur l'ancien moteur équipé de 2 sondes de température d'eau (une indication tableau de bord - une pour le boîtier d'injection Renix), j'ai ajouté un thermocouple pour le contrôle.
Résultat : 105°C au calculateur, 90°C au thermocouple, 80°C au tableau de bord :oops: :oops:
Je ne suis malheureusement pas surpris de cette information :-(

Un jour il faudra bien que je vous communique les bons fichiers .inc...
En attendant n'hésitez pas à étalonner vos sondes par trois points "mesurés"

++
Manu
 #8507  par Phil 911 SC
 21 mai 2019 21:41
Salut Gégé,
Pour la T° d'huile de ma voiture, j'utilise un capteur VDO 323 805 001 001N.
Voici sa courbe. C'est un M14x150
Screen Shot 05-21-19 at 09.40 PM.JPG
 #8517  par Gégé13821
 23 mai 2019 08:06
Phil 911 SC a écrit :
21 mai 2019 21:41
Pour la T° d'huile de ma voiture, j'utilise un capteur VDO 323 805 001 001N.
Voici sa courbe. C'est un M14x150
Merci Phil pour l'information.
Waouh :!: :!: Bravo la courbe - Précision Porsche ;) ;)
 #8518  par Gégé13821
 23 mai 2019 08:27
J'ai du rater quelque chose !!!
J'ai démarré mon moteur avec les injecteurs d'origine :
Bosch 0 280 150 762. J'ai trouvé 214 cc/min à 3 bars, 16 ohms (mais non contrôlé).

Pour pouvoir ajouter de l'éthanol, j'ai changé mes injecteurs par des :
Bosch 0 280 150 558. Vendus pour 440 cc/min à 3 bars.

D'après les différentes formules le temps d'injection est directement proportionnel à ReqFuel.
Avec les 214 cc/mn ReqFuel = 15.6
Avec les 440 cc/mn ReqFuel = 7.6
Jusque là, tout est logique, quand on double le débit, on divise par deux le temps :ugeek: :ugeek:

Mais aux premiers essais, le résultat est beaucoup trop pauvre (AFR supérieur à 15-16).
Un rapide contrôle avec MegaLogViewer et VEAnalyse : il faut ajouter 40 % aux valeurs de la table VE.

Nouvelle valeur de ReqFuel = 9.5 (je triche pour limiter la modification de la table VE).
Nouvel essai avec Tuner Studio et Auto-Apprentissage .... Les cellules sont augmentées d'environ 20% (confirmation des 40%) :oops: :oops:

Peut être une mauvaise valeur du temps d'ouverture des injecteurs : 0.9 ms (dans les deux cas) :?: :?:

Si vous avez des pistes de réflexion, je suis preneur ;) ;)
Pour l'instant, je sèche :roll: :roll:
 #8521  par Manu
 23 mai 2019 17:21
Bonjour,

Une réponse définitive à cette question n'est pas envisageable car il y a beaucoup de facteurs qui rentrent en compte et que l'aspect "Efficacité Volumétrique" n'est vrai que dans une configuration bien précise. Donc sans ton projet c'est assez délicat de répondre.

Mais ta pensée relative au temps mort des injecteurs est une réalité, malheureusement souvent sous-estimée. En effet, tu dis avoir mis 0,9ms de temps mort. On s’aperçoit souvent que sur des générations d'injecteur récent, le temps mort est plus proche de 0,3ms ! (3 fois moins).

Donc, pour pouvoir se dire : je travaille en VE et si je veux changer mes injecteurs c'est bon, il faut commencer par bien caractériser les éléments. C'est vital ! Et les premiers éléments à caractériser sont les injecteurs, dans leur ensemble. C'est long et fastidieux. Donc en général personne ne le fait et les gens préfèrent refaire un réglage en changeant d'injecteurs. Ce n'est pas la plus mauvaise manière car même un injecteur bien caractérisé peut nécessiter un léger re-réglage en cas de changement. En effet, outre les caractéristiques "standard" telles les temps morts, débit, impédance, etc., il y a des caractéristiques qui influent également sur le mélange et qui sont difficilement caractérisables. Je pense notamment à la forme du jet de carburant...

Pour *réellement* caractériser les injecteurs, il faut le faire avec son propre calculateur et son propre circuit de carburant ! Chaque calculateur possède une réponse différente, au moins chaque marque ou modèle. Pour caractériser ses injecteurs on va donc utiliser le mode test du calculateur et faire pisser les injecteurs dans des fioles graduées. Déjà c'est pas facile à mettre en œuvre de manière sécurisée.

Ensuite on va répéter plusieurs fois le test avec des valeurs de temps d'injection différentes afin de pouvoir déterminer le débit, le temps mort et visualiser la non-linéarité des injecteurs. Uniquement à ce moment là on peut dire que :
  1. Les injecteurs sont caractérisés
  2. le table VE sera bien une table d'efficacité volumétrique, puisqu'elle ne sera pas perturbée par une mauvaise caractérisation des injecteurs
Je rappelle que les injecteurs récents peuvent avoir un temps mort de 0,3ms, là ou tu as indiqué 0,9 !!! Imagine la dérive sur la table VE !

Sportivement,
Manu
 #8522  par Manu
 23 mai 2019 17:28
Et pour te donner une idée du travail a réaliser, et des résultats qu'on obtient, voici un fichier excel qui caractérise les injecteurs DEKA/SIEMENS 630cc vendus sur la boutique. Ces tests ont étés réalisés avec un calculateur MS3+X.

Débit réel sous 3 bar : 598cc.
Temps mort effectif : 0,4ms

Et regarde la 'non-linéarité' en deçà de 2ms. Cette non linéarité est caractérisable sur les calculateurs MS3.

Tu comprends que si tu changes tes injecteurs, il faut à minima les re-caractériser. La table VE ne tient pas compte de cela, mais uniquement du remplissage. Foire cette phase, et la table VE n'est plus une table VE ;-)
Fichiers joints
(32 Kio) Téléchargé 10 fois
  • 1
  • 30
  • 31
  • 32
  • 33
  • 34