Support officiel calculateurs Megasquirt, Lambda Tech Edge WBO2, Tuner Pro, SportDevices et Fenixecu 

  • BMW M5 e34 S38B36 / S38B38

  • Vos montages, vos projets, vos remarques, c'est ici ;-)
Vos montages, vos projets, vos remarques, c'est ici ;-)
 #7463  par Manu
 02 mai 2018 19:33
Salut,

Ce n'est pas vrai...
 #7471  par vozhd
 04 mai 2018 19:53
En cherchant encore j'ai en effet trouvé des profils pour moteurs S38 nommés "startup map" ...mais pour megasquirtPNP sur base MS2 (Fw 3.2.1 et 3.3.1a).

Et quand tu dis "ce n'est pas vrai", tu veux dire que ces msq ne sont pas utilisables pour une MS3 ?
 #7473  par Manu
 04 mai 2018 22:37
vozhd a écrit :
02 mai 2018 18:17
Megasquirt has an S38 tune built into their software, this is the tune we started with on my M90 with an S38B38 crank.
.

Si c'est verifie ca ferait une bonne base de depart pour moi.
Littéralement : Les calculateurs Megasquirt possèdent une cartographie S38 INTÉGRÉE (built into) dans le logiciel.
C'est ça qui est faux. Les calculateurs Megasquirt, quels qu'ils soient, ne possèdent pas de cartographie S38 INTÉGRÉE !!!

Par contre le fichier que tu as trouvé, si tu est sûr de la source, peut être un point de départ. Les calculateurs MSPNP2 possèdent une cartographie de démarrage intéressante et il est facile de prendre les informations pertinentes et de les transférer (à la main, une à une) dans un calculateur MS3.

Sportivement,
Manu
 #7479  par vozhd
 05 mai 2018 22:06
Salut Manu,

Merci de ta réponse.
j'ai trouvé les fichiers sur cette page: http://www.megasquirtpnp.com/mspnp2_maps.php.
ce sont ceux intitulés "S38 M5 startup map".

Les liens et la banner de pied de base renvoient chez diyautotune.com donc j'aurai plutôt tendance à être confiant.
Si je comprends bien la MS3 ne pourra pas utiliser ce fichier directement mais je peux l'utiliser comme modèle pour bâtir un profil de demarrage équivalent sur la MS3.
Ce qui revient à peu près au même, de façon indirecte.
ça me convient.
je vais donc pouvoir me lancer dans la réalisation.
 #7632  par LR78
 14 juin 2018 22:17
Bonsoir

J'ai monté un système MS3 x sur un BMW M62b44 (v8 4.4l) il y a 4/5 ans maintenant, il n'a jamais démarré avec les tunes glanés sur le Net...... :o

J'ai finalement pris une feuille blanche, la plan du faisceau et pas à pas le système s'est constitué : allumage puis injection, puis régulation ralenti ... au départ en full puis en séquentiel map/vitesse puis finalement en full group papillon/ vitesse.... Le système a parfaitement fonctionné pendant 3 ans puis l'auto est partie vers un autre proprio ...

P.s. : mon moteur n'avait pas de Vanos.
 #7656  par vozhd
 21 juin 2018 12:22
Salut,

J'ai lu tous tes posts sur ce forum et ton blog ou tu racontais la mise en place du ms3x.
Je ne cherchais pas un setup utilisable en plug&play mais simplement une base pour demarrer (mon travail, pas le moteur).
les setups dont je parle proviennent directement de chez diyautotune.com, a priori je peux m'y fier dans une certaine mesure (de ce que j'en ai vu pour le moment, ils n'utilisent pas le mode que je prevois d'utiliser [full-sequential / COP] et meme les infos de base ne sont pas correctes [cylindree et PW de base]. en revanche les maps AFR / VE / ignition sont plausibles).

Pour le moment je suis en train de cabler le faisceau et de lire attentivement le manuel de ma ms3.
Au moins 50% de mon objectif consiste a apprendre / comprendre / approfondir la gestion d'un moteur. Utiliser un setup tout fait, brancher les prises et tourner la clef ne m'interesse pas outre-mesure.

je mettrai a jour ce topic quand j'aurai une progression interessante a raconter.. ;)
 #8099  par vozhd
 15 déc. 2018 02:55
Salut,

Après pas mal de boulot (distri, étanchéïté carters, support filtre à huile, remplacement trains roulants, remplacement berceau et direction...) dont quelques travaux imprévus, j'espérais vous annoncer enfin avoir réussi a démarrer le moteur sur la MS3pro.
J'en suis aux étapes de contrôles, section 6 du manuel:
-alimentation / relai principal OK
-pompe à essence et son relai OK
-calibration et valeurs retour CLT / IAT / TPC OK
-calibration sonde AFR supposée OK (retour AFR 19.99 moteur éteint)
-pilotage des injecteurs OK

mais le seul point qui comportait une zone de flou n'a pas manqué de poser problème:
-pilotage des bobines NOK a priori

Comme annoncé j'utilise des bobines COP originales BMW de marque BREMI en mode séquentiel:
-sachant que ce sont des COP et pas une bobine à coupelle j'ai revu les temps de dwell à la baisse pour ne pas les cuire (3.5ms, batterie à 12.3V).
-sachant que ce sont des bobines sans allumeur, j'ai utilisé des BIP373 pour que le pilotage logique 5V des sorties de la MS3pro puisse commander le primaire des bobines en 12V.
cablage comme indiqué sur sur tous les documents que j'ai pu trouver sur le sujet.

borne B: commande logique depuis la MS3pro avec résistance 330ohm en série
borne C: vers commande de la bobine
borne E: vers masse
+ montage avec rondelle plastique et feuille mica pour isolation par rapport au dissipateur thermique

comme ça n'a pas fonctionné j'ai vérifié:
-les bobines sont bien alimentées en +12V sur une borne
-les bobines sont bien connectées à la masse sur la borne centrale

j'ai eu un doute au niveau de mon cablage alors j'ai ouvert mon faisceau adaptateur MS3pro <-> motronic 3.3

c'est là que j'ai trouvé plusieurs de pattes des BIP373 rompues :o
elles sont visiblement plus souples que les fils de faisceau MS3 et en l'absence d'immobilisation, elles plient et replient, et finissent par casser.
j'ai donc jeté ces IGBT et mon montage est HS pour ce qui concerne l'injection.
je vais retenter une installation du même genre, coulée dans de la résine époxy pour assurer l'immobilisation des pattes des IGBT (qui seront peut-etre des bosch 30053 récupérés de calculateurs motronic ou autres).
sinon je serai forcé d'en passer par des MTR04 ou équivalents...

en cherchant dans la FAQ de la page BIP373 j'ai trouvé une réponse indiquant que pour les MS3pro la résistance en série à utiliser sur l'entrée est une 100ohm, pas une 330ohm. l'auteur précise d'ailleurs que les "quadspark" sont construits ainsi.
Mon problème d'absence d'étincelle pouvait donc avoir pour origine:
-patte IGBT rompue
-valeur de résistance inappropriée
-voire ...mauvaise isolation des IGBT par rapport au dissipateur thermique en alu

ces 3 aspects vont être revus et corrigés en une seule étape.

vos remarques sont les bienvenues.
Si quelqu'un a l'expérience de l'utilisation des bobines COP BMW (Bremi, Bosch) et/ou du montage IGBT qui permet de les déclencher...

Je sais aussi qu'il serait possible d'utiliser des bobines embarquant leur propre allumeur cependant il faut noter que j'utilise un faisceau moteur BMW original, le connecteur est donc spécialement adapté aux bobines BMW ...celles sans allumeur intégré.
 #8101  par vozhd
 16 déc. 2018 23:46
Salut les amis,

La partie allumage HS n'empêche pas de continuer à tester le reste...

- pilotage electrovanne de gestion de ralenti PWM 3fils OK
- vérification des signaux CKP / CMP ...n'ont pas l'air trop mal:
-> tooth logger: tout les 58 barres, 1 barre ~x2.5 plus haute, colle avec le modèle 60-2.
-> composite logger: en haut, une barre verte (CMP) tous les 2 "trous" sur les ocsillations en bleu (CKP). tout en bas la ligne rouge reste plate (pas d'erreur donc).
reste à voir si le signal CMP est produit à un moment convenable (mécaniquement sa postion sur la poulie d'acc n'est pas variable).
Fichiers joints
tooth_logger.png
tooth_logger.png (24.93 Kio) Vu 472 fois
composite_logger.png
composite_logger.png (5.65 Kio) Vu 472 fois
 #8105  par vozhd
 18 déc. 2018 19:34
page 71 du manuel:
the cam sensor can be at any angle except having the active edge aligned in the tooth gap.


C'est balot, où qu'elle est la "cam tooth" ?
pile-poil dans le "tooth gap" de la roue phonique, là où précisément il ne faut pas. :lol:

Du coup, modification du réglage pour le capteur d'AAC en "front montant" plutôt que front descendant.
c'est mieux:
Fichiers joints
composite_logger_risingSec.png
composite_logger_risingSec.png (9.84 Kio) Vu 463 fois
 #8106  par Manu
 18 déc. 2018 20:05
Je voulais pas le dire mouarf